Locked

Skype on Arch 64-bit

Sep
18
2011

Linux

I was having some trouble getting Skype to work on my Arch Linux x86_64 machine, but I manged to get it sorted out. Here is how I solved it:
yaourt -S bin32-skype

then when trying to run it I got the error message
skype: error while loading shared libraries: libXv.so.1: wrong ELF class: \\
ELFCLASS64

To see which libraries were missing I used the command
ldd /usr/bin/skype | grep not

which returned
libXv.so.1 => not found
libXss.so.1 => not found

Aha! So I then installed these with Yaourt
yaourt -S lib32-libxv lib32-libxss

and voilá, Skype is running natively!









Back